请选择 进入手机版 | 继续访问电脑版

汇总:如何量化表达勾头拐点分型?

[复制链接]
查看129 | 回复5 | 张孟珂 | 2020-6-10 11:31:39 | 显示全部楼层 |阅读模式
涨跌如何去表达?今天我们从MACD、均线、K线、交易量这4个指标出发,去对涨跌进行描述。


MACD、均线、K线、交易量和VA鱼、F32组合在一起后就可以去描述涨跌,例如MACD柱VA鱼、MACD柱F32、K线VA鱼、交易量VA鱼等组合方法。
微信图片_20200611115646.png


关于VA鱼和F32的使用方法,推荐阅读:
1. VA鱼是多少?
2. F32如何理解?

一、MACD指标表达涨跌的方法
1. 金叉死叉
2. DEA线和零轴关系
3. 柱VA鱼
4. 柱F32
5. 线F32
6. DEA线创新高新低

二、均线指标
表达涨跌的方法
1. 金叉死叉
2. 均线F32
3. VA鱼
4. 均线方向
5. 快线慢线
6. 均线排列组合

三、K线
指标表达涨跌的方法
1. K线F32
2. K线VA鱼
3. K线+单根均线
4. 单均线创新高新低
5. 今日昨日比例

四、交易量
指标表达涨跌的方法
1. 均线金叉死叉
2. 均线方向
3. 柱VA鱼
4. 均线VA鱼
5. 柱F32
6. 均线F32
7. 快线慢线
8. 柱新高新低
9. 今日昨日比例

回复

使用道具 举报

张孟珂 | 2020-6-10 13:25:46 | 显示全部楼层
表达涨跌方法的代码汇总:【N1:20;N2:0.5;N3:0.5】
//一、定义MACD指标
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  := EMA(DIFF,9);
MACD := 2*(DIFF-DEA),COLORSTICK;//DIFF减DEA的2倍画柱状线

//方法一、MACD指标表达涨跌的方法
//1、金叉死叉
MACDJC := CROSSUP(DIFF, DEA);
MACDSC := CROSSDOWN(DIFF, DEA);

//2、DEA线和零轴关系
DEAS0 := CROSSUP(DEA, 0);
DEAX0 := CROSSDOWN(DEA, 0);

//3、柱VA鱼(柱子长短变化)
MACDV := MACD>REF(MACD, 1) AND REF(MACD, 2)>REF(MACD, 1);
MACDA := MACD<REF(MACD, 1) AND REF(MACD, 2)<REF(MACD, 1);

//4、柱F32(3根柱子里面有至少2个变长)
MACDF32 := IF(COUNT(MACD>REF(MACD, 1), 3)>=2 ,1 ,-1);

//5、DEA线F32(3天中至少有2天向上)
DEA_F32 := IF(COUNT(DEA>REF(DEA, 1), 3)>=2 ,1 ,-1);

//6、DEA线创新高新低【N1 默认为20】
DEACXG := DEA=HV(DEA, N1);
DEACXD := DEA=LV(DEA, N1);

//方法二、均线指标表达涨跌的方法
MA5 := MA(CLOSE, 5);//周均线
MA20 := MA(CLOSE, 20);//月均线
MA60 := MA(CLOSE, 60);//季均线
MA120 := MA(CLOSE, 120);//半年均线
MA240 := MA(CLOSE, 240);//年均线
//1、金叉死叉
JXJC := CROSSUP(MA5, MA20);
JXSC := CROSSDOWN(MA5, MA20);

//2、均线F32
JX_F32 := IF(COUNT(MA5>REF(MA5, 1), 3)>=2 ,1 ,-1);

//3、VA鱼
JXV := MA5>REF(MA5, 1) AND REF(MA5, 2)>REF(MA5, 1);
JXA := MA5<REF(MA5, 1) AND REF(MA5, 2)<REF(MA5, 1);

//4、均线方向
JXFXS := MA5 > REF(MA5, 1);
JXFXX := MA5 < REF(MA5, 1);

//5、快线慢线
JXKMS := MA5>MA20;
JXKMX := MA5<MA20;

//6、均线排列组合
MA12345 := MA5>MA20&&MA20>MA60&&MA60>MA120&&MA120>MA240;
MA54321 := MA5<MA20&&MA20<MA60&&MA60<MA120&&MA120<MA240;


//方法三、K线表达涨跌的方法
//1、K线F32(3根K线中至少2根阳线)
K_F32 := IF(COUNT(ISUP,3)>=2 ,1,-1);

//2、K线VA鱼(用收盘价表示)
KV := C>REF(C, 1) AND REF(C, 2)>REF(C, 1);
KA := C<REF(C, 1) AND REF(C, 2)<REF(C, 1);

//3、K线+单根均线
KJXS := C>MA5;
KJXX := C<MA5;

//4、单均线创新高新低【N1 默认为20】
KCXG := C=HV(C, N1);
KCXD := C=LV(C, N1);

//5、今日昨日比例
KBLS := C/REF(C, 1)>N2;
KBLX := C/REF(C, 1)<N2;


//方法四、定义交易量--多种表达方法
JYLMA5 := MA(VOL, 5);//交易量周均线
JYLMA20 := MA(VOL, 20);//交易量月均线
JYLMA60 := MA(VOL, 60);//交易量季均线
JYLMA120 := MA(VOL, 120);//交易量半年均线
JYLMA240 := MA(VOL, 240);//交易量年均线
//1、金叉死叉
JYLJC := CROSSUP(JYLMA5, JYLMA20);
JYLSC := CROSSDOWN(JYLMA5, JYLMA20);

//2、均线方向
JYLFXS := JYLMA5>REF(JYLMA5, 1);
JYLFXX := JYLMA5<REF(JYLMA5, 1);

//3、柱VA鱼
JYLV := VOL>REF(VOL, 1) AND REF(VOL, 2)>REF(VOL, 1);
JYLA := VOL<REF(VOL, 1) AND REF(VOL, 2)<REF(VOL, 1);

//4、均线VA鱼
JYLMAV := JYLMA5>REF(JYLMA5, 1) AND REF(JYLMA5, 2)>REF(JYLMA5, 1);
JYLMAA := JYLMA5<REF(JYLMA5, 1) AND REF(JYLMA5, 2)<REF(JYLMA5, 1);

//5、柱F32
VOLF32 := IF(COUNT(VOL>REF(VOL, 1), 3)>=2 ,1,-1);

//6、均线F32
JYL_F32 := IF(COUNT(JYLMA5>REF(JYLMA5, 1), 3)>=2 ,1,-1);

//7、快线慢线
JYLKMS := JYLMA5>JYLMA20;
JYLKMX := JYLMA5<JYLMA20;

//8、柱创新高新低【N1 默认为20】
VOLCXG := VOL=HV(VOL, N1);
VOLCXD := VOL=LV(VOL, N1);

//9、今日昨日比例
JYLBLS := VOL/REF(VOL, 1)>N3;
JYLBLX := VOL/REF(VOL, 1)<N3;
回复

使用道具 举报

春江 | 2020-6-10 15:51:01 | 显示全部楼层
老师,这个帖子是什么意思?提示一下,好像一点都 不能理解呀
回复

使用道具 举报

桥博士 | 2020-6-10 17:02:08 | 显示全部楼层
这几天,我会录一节课程
回复

使用道具 举报

西瓜 | 2020-6-11 08:21:36 | 显示全部楼层
是不是给我们做K线判断多些语句?
回复

使用道具 举报

桥博士助教 | 2020-6-11 15:32:06 | 显示全部楼层
西瓜 发表于 2020-6-11 08:21
是不是给我们做K线判断多些语句?

是个汇总贴
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

相关课程推荐
桥博士《MACD指标详解》
为什么我们只用MACD金叉死叉来进行操作效果并不好,学习课程就能在研究MACD指标上少走很多弯路
桥博士《K线形态组合解析》
从理论到实战,让您全面掌握各种K线形态及各种组合,帮您分析梳理大量K线知识让您的投资更游刃有余
桥博士《股票入门基础知识》
从理论到实战,课程包括如何买卖股票、开户流程、交易软件、k线图知识、技术指标、价值投资等新手必备知识

42

主题

231

帖子

728

积分

高级会员

Rank: 4

积分
728
  • 官方论坛

    提供最新 Discuz! 产品新闻、软件下载与技术交流