请选择 进入手机版 | 继续访问电脑版

SAR指标测试和代码版本汇总

[复制链接]
查看45 | 回复4 | 王博 | 2020-4-15 17:32:02 | 显示全部楼层 |阅读模式
1)定义SAR的计算公式:
文字描述:SAR指标是用来设置移动止损的,当价格触碰止损位,表示市场趋势反转。
量化定义:STEP1:=2/100;
                  MVALUE1:=20/100;
                  SARLINE:=SAR(4,STEP1,MVALUE1);
                  IF(SARLINE>=0,SARLINE,NULL),COLORRED,CIRCLEDOT;
                  IF(SARLINE<0,ABS(SARLINE),NULL),COLORCYAN,CIRCLEDOT;

2) 定义测试的买卖逻辑:
A. 测试的买入条件:若SARLINE>0时,则以当日收盘价买入;
B. 测试的卖出条件:若SARLINE<0时,则以当日收盘价卖出

3) 定义测试的品种和时间:
测试品种:上证指数
测试周期:2000-02-01 到 2020-01-31

回复

使用道具 举报

王博 | 2020-4-15 17:33:36 | 显示全部楼层
测试一代码:

//一、定义仓位
FUND:=10000000;
LOTS:=INTPART(FUND*0.8/(CLOSE+FEE));//计算手数,使每次开仓金额都是800W

STEP1:=2/100;
MVALUE1:=20/100;
SARLINE:=SAR(4,STEP1,MVALUE1);
IF(SARLINE>=0,SARLINE,NULL),COLORRED,CIRCLEDOT;
IF(SARLINE<0,ABS(SARLINE),NULL),COLORCYAN,CIRCLEDOT;

SARR1:=SARLINE>0;//SAR红点
SARR2:=SARLINE<0;//SAR绿点

SARR1,BK(LOTS);
SARR2,SP(BKVOL);

回复

使用道具 举报

王博 | 2020-4-15 17:36:46 | 显示全部楼层
测试二代码:

//一、定义仓位
FUND:=10000000;
LOTS:=INTPART(FUND*0.8/(CLOSE+FEE));//计算手数,使每次开仓金额都是800W

STEP1:=STEP/100;
MVALUE1:=MVALUE/100;
SARLINE:SAR(N,STEP1,MVALUE1),CIRCLEDOT;
IF(SARLINE>=0,SARLINE,NULL),COLORRED,CIRCLEDOT;
IF(SARLINE<0,ABS(SARLINE),NULL),COLORCYAN,CIRCLEDOT;

SARR1:=SARLINE>0;//SAR红点
SARR2:=SARLINE<0;//SAR绿点

SARR1,BK(LOTS);
SARR2,SP(BKVOL);

回复

使用道具 举报

王博 | 2020-4-15 17:46:20 | 显示全部楼层
测试三代码:

//一、定义仓位
FUND:=10000000;
LOTS:=INTPART(FUND*0.8/(CLOSE+FEE));//计算手数,使每次开仓金额都是800W

STEP1:=2/100;
MVALUE1:=20/100;
SARLINE:=SAR(4,STEP1,MVALUE1);
IF(SARLINE>=0,SARLINE,NULL),COLORRED,CIRCLEDOT;
IF(SARLINE<0,ABS(SARLINE),NULL),COLORCYAN,CIRCLEDOT;

SARR1:=SARLINE>0;//SAR红点
SARR2:=SARLINE<0;//SAR绿点
CJL1:=VOL>MA(VOL,20);//定义放量

SARR1 AND CJL1,BK(LOTS);
SARR2,SP(BKVOL);

回复

使用道具 举报

王博 | 2020-4-15 17:49:00 | 显示全部楼层
测试四代码:

//定义仓位
FUND:=10000000;
LOTS:=INTPART(FUND*0.8/(CLOSE+FEE));//计算手数,使每次开仓金额都是800W

STEP1:=2/100;
MVALUE1:=20/100;
SARLINE:=SAR(4,STEP1,MVALUE1);
IF(SARLINE>=0,SARLINE,NULL),COLORRED,CIRCLEDOT;
IF(SARLINE<0,ABS(SARLINE),NULL),COLORCYAN,CIRCLEDOT;

SARR1:=SARLINE>0;//SAR红点
SARR2:=SARLINE<0;//SAR绿点

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;//收盘价与N周期最低值做差,N周期最高值与N周期最低值做差,两差之间做比值。
K:=SMA(RSV,3,1);//RSV的移动平均值
D:=SMA(K,3,1);//K的移动平均值
J:=3*K-2*D;

KDJ1:=CROSSUP(K,D);//KDJ金叉

SARR1 AND KDJ1 AND D>50,BK(LOTS);
SARR2,SP(BKVOL);

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

相关课程推荐
桥博士《MACD指标详解》
为什么我们只用MACD金叉死叉来进行操作效果并不好,学习课程就能在研究MACD指标上少走很多弯路
桥博士《K线形态组合解析》
从理论到实战,让您全面掌握各种K线形态及各种组合,帮您分析梳理大量K线知识让您的投资更游刃有余
桥博士《股票入门基础知识》
从理论到实战,课程包括如何买卖股票、开户流程、交易软件、k线图知识、技术指标、价值投资等新手必备知识

79

主题

446

帖子

1081

积分

金牌会员

Rank: 6Rank: 6

积分
1081
  • 官方论坛

    提供最新 Discuz! 产品新闻、软件下载与技术交流