请选择 进入手机版 | 继续访问电脑版

QMACD副图指标

[复制链接]
查看175 | 回复0 | 桥博士 | 2020-9-18 15:43:10 | 显示全部楼层 |阅读模式
//QMACD
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  : EMA(DIFF,9);
2*(DIFF-DEA),COLORSTICK;
MACD:2*(DIFF-DEA),COLORSTICK;


MACDV:=MACD>REF(MACD,1) AND REF(MACD,2)>REF(MACD,1);
MACDA:=MACD<REF(MACD,1) AND REF(MACD,2)<REF(MACD,1);
LEN:=CONDBARS(CROSSUP(DIFF,DEA),CROSSDOWN(DIFF,DEA));
DDAI:=C>REF(C,LEN) AND CROSSDOWN(DIFF,DEA);
KDAI:=C<REF(C,LEN) AND CROSSUP(DIFF,DEA);   
DDUAN:=C<=REF(C,LEN) AND CROSSDOWN(DIFF,DEA);
KDUAN:=C>=REF(C,LEN) AND CROSSUP(DIFF,DEA);   
DDAICS:=-1*COUNT(DDAI,0);
DDK := IF(BARSLAST(DDAI)<BARSLAST(KDAI), 1, -1);

//MACD标记
DRAWTEXT(DDAI ,DIFF,'D'),ALIGN1,FONTSIZE32,COLORRED;
DRAWTEXT(DDUAN ,DIFF ,'D'),ALIGN1,FONTSIZE24,COLORGRAY;
DRAWTEXT(KDAI ,DEA,'C'),VALIGN0,FONTSIZE32,COLORRED;
DRAWTEXT(KDUAN ,DEA,'C'),VALIGN0,FONTSIZE24,COLORGRAY;

////////////////////////////////////////////////////////////////////////////


DYT:=MACDV;
KYT:=MACDA;
FBPK := DYT AND COUNT(DYT, BARSLAST(KYT))=1;
FSPK := KYT AND COUNT(KYT, BARSLAST(DYT))=1;
BPKC := IF(FBPK , C, REF(C, BARSLAST(FBPK)));
SPKC := IF(FSPK , C, REF(C, BARSLAST(FSPK)));

LEN1 := CONDBARS(FBPK, FSPK);
DDAI1 := C>REF(C,LEN1) AND FSPK;
KDAI1 := C<REF(C,LEN1) AND FBPK;
DDUAN1 := C<=REF(C,LEN1) AND FSPK;
KDUAN1 := C>=REF(C,LEN1) AND FBPK;

DRAWTEXT(DDAI1 ,MACD ,'A'),ALIGN1,FONTSIZE24,COLORBLUE;//
DRAWTEXT(DDUAN1 ,MACD ,'A'),ALIGN1,FONTSIZE16,COLORWHITE;//
DRAWTEXT(KDAI1 ,MACD,'V'),VALIGN0,FONTSIZE24,COLORBLUE;//
DRAWTEXT(KDUAN1 ,MACD ,'V'),VALIGN0,FONTSIZE16,COLORWHITE;//

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

相关课程推荐
桥博士《MACD指标详解》
为什么我们只用MACD金叉死叉来进行操作效果并不好,学习课程就能在研究MACD指标上少走很多弯路
桥博士《K线形态组合解析》
从理论到实战,让您全面掌握各种K线形态及各种组合,帮您分析梳理大量K线知识让您的投资更游刃有余
桥博士《股票入门基础知识》
从理论到实战,课程包括如何买卖股票、开户流程、交易软件、k线图知识、技术指标、价值投资等新手必备知识

153

主题

660

帖子

1938

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1938
  • 官方论坛

    提供最新 Discuz! 产品新闻、软件下载与技术交流