请选择 进入手机版 | 继续访问电脑版

TMACD-附图指标

[复制链接]
查看76 | 回复2 | 桥博士 | 2020-7-21 21:46:35 | 显示全部楼层 |阅读模式
//TMACD 同梁MACD
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA  : EMA(DIFF,M);
2*(DIFF-DEA),COLORSTICK;
MACD:2*(DIFF-DEA),COLORSTICK;

//MACDVA鱼
MACDV:=MACD>REF(MACD,1) AND REF(MACD,2)>REF(MACD,1);
MACDA:=MACD<REF(MACD,1) AND REF(MACD,2)<REF(MACD,1);
LEN:=CONDBARS(CROSSUP(DIFF,DEA),CROSSDOWN(DIFF,DEA));
DDAI:=C>REF(C,LEN) AND CROSSDOWN(DIFF,DEA); //MACD多带鱼
KDAI:=C<REF(C,LEN) AND CROSSUP(DIFF,DEA);   //MACD空带鱼
DDUAN:=C<=REF(C,LEN) AND CROSSDOWN(DIFF,DEA); //MACD空带鱼
KDUAN:=C>=REF(C,LEN) AND CROSSUP(DIFF,DEA);   //MACD空短鱼
DDAICS:=-1*COUNT(DDAI,0);
DDK := IF(BARSLAST(DDAI)<BARSLAST(KDAI), 1, -1);

//MACD标记
DRAWTEXT(DDAI ,DIFF,'空'),VALIGN2,FONTSIZE24,COLORRED;
DRAWTEXT(DDUAN ,DIFF ,'空'),VALIGN2,FONTSIZE16,COLORGREEN;
DRAWTEXT(KDAI ,DEA,'多'),VALIGN0,FONTSIZE24,COLORRED;
DRAWTEXT(KDUAN ,DEA,'多'),VALIGN0,FONTSIZE16,COLORGREEN;

////////////////////////////////////////////////////////////////////////////

//MACD柱VA鱼
DYT:=MACDV;
KYT:=MACDA;
FBPK := DYT AND COUNT(DYT, BARSLAST(KYT))=1;
FSPK := KYT AND COUNT(KYT, BARSLAST(DYT))=1;
BPKC := IF(FBPK , C, REF(C, BARSLAST(FBPK)));
SPKC := IF(FSPK , C, REF(C, BARSLAST(FSPK)));

LEN1 := CONDBARS(FBPK, FSPK);
DDAI1 := C>REF(C,LEN1) AND FSPK;
KDAI1 := C<REF(C,LEN1) AND FBPK;
DDUAN1 := C<=REF(C,LEN1) AND FSPK;
KDUAN1 := C>=REF(C,LEN1) AND FBPK;

DRAWTEXT(DDAI1 ,MACD ,'A'),ALIGN2,FONTSIZE24,COLORBLUE;//VA鱼多带
DRAWTEXT(DDUAN1 ,MACD ,'A'),ALIGN2,FONTSIZE16,COLORWHITE;//VA鱼多短
DRAWTEXT(KDAI1 ,MACD,'V'),ALIGN2,FONTSIZE24,COLORBLUE;//VA鱼空带
DRAWTEXT(KDUAN1 ,MACD ,'V'),ALIGN2,FONTSIZE16,COLORWHITE;//VA鱼空短

回复

使用道具 举报

张孟珂 | 2020-7-22 11:39:14 | 显示全部楼层
微信图片_20200722113701.png


//TMACD 同梁MACD 【SHORT 12; LONG  26 ; M 9】
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA  : EMA(DIFF,M);
2*(DIFF-DEA),COLORSTICK;
MACD:2*(DIFF-DEA),COLORSTICK;

//MACDVA鱼
MACDV:=MACD>REF(MACD,1) AND REF(MACD,2)>REF(MACD,1);
MACDA:=MACD<REF(MACD,1) AND REF(MACD,2)<REF(MACD,1);
LEN:=CONDBARS(CROSSUP(DIFF,DEA),CROSSDOWN(DIFF,DEA));
DDAI:=C>REF(C,LEN) AND CROSSDOWN(DIFF,DEA); //MACD多带鱼
KDAI:=C<REF(C,LEN) AND CROSSUP(DIFF,DEA);   //MACD空带鱼
DDUAN:=C<=REF(C,LEN) AND CROSSDOWN(DIFF,DEA); //MACD空带鱼
KDUAN:=C>=REF(C,LEN) AND CROSSUP(DIFF,DEA);   //MACD空短鱼
DDAICS:=-1*COUNT(DDAI,0);
DDK := IF(BARSLAST(DDAI)<BARSLAST(KDAI), 1, -1);

//MACD标记
DRAWTEXT(DDAI ,DIFF,'多'),VALIGN2,FONTSIZE24,COLORRED;//MACD多带
DRAWTEXT(DDUAN ,DIFF ,'多'),VALIGN2,FONTSIZE16,COLORGREEN;//MACD多短
DRAWTEXT(KDAI ,DEA,'空'),VALIGN0,FONTSIZE24,COLORRED;//MACD空带
DRAWTEXT(KDUAN ,DEA,'空'),VALIGN0,FONTSIZE16,COLORGREEN;//MACD空短

////////////////////////////////////////////////////////////////////////////

//MACD柱VA鱼
DYT:=MACDV;
KYT:=MACDA;
FBPK := DYT AND COUNT(DYT, BARSLAST(KYT))=1;
FSPK := KYT AND COUNT(KYT, BARSLAST(DYT))=1;
BPKC := IF(FBPK , C, REF(C, BARSLAST(FBPK)));
SPKC := IF(FSPK , C, REF(C, BARSLAST(FSPK)));

LEN1 := CONDBARS(FBPK, FSPK);
DDAI1 := C>REF(C,LEN1) AND FSPK;
KDAI1 := C<REF(C,LEN1) AND FBPK;
DDUAN1 := C<=REF(C,LEN1) AND FSPK;
KDUAN1 := C>=REF(C,LEN1) AND FBPK;

DRAWTEXT(DDAI1 ,MACD ,'A'),ALIGN2,FONTSIZE24,COLORBLUE;//VA鱼多带
DRAWTEXT(DDUAN1 ,MACD ,'A'),ALIGN2,FONTSIZE16,COLORWHITE;//VA鱼多短
DRAWTEXT(KDAI1 ,MACD,'V'),ALIGN2,FONTSIZE24,COLORBLUE;//VA鱼空带
DRAWTEXT(KDUAN1 ,MACD ,'V'),ALIGN2,FONTSIZE16,COLORWHITE;//VA鱼空短
回复

使用道具 举报

桥博士 | 2020-7-22 23:46:46 | 显示全部楼层
不是的
我有意这么改的
带鱼命名的逻辑要和VA命名逻辑一致
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

相关课程推荐
桥博士《MACD指标详解》
为什么我们只用MACD金叉死叉来进行操作效果并不好,学习课程就能在研究MACD指标上少走很多弯路
桥博士《K线形态组合解析》
从理论到实战,让您全面掌握各种K线形态及各种组合,帮您分析梳理大量K线知识让您的投资更游刃有余
桥博士《股票入门基础知识》
从理论到实战,课程包括如何买卖股票、开户流程、交易软件、k线图知识、技术指标、价值投资等新手必备知识

132

主题

588

帖子

1681

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1681
  • 官方论坛

    提供最新 Discuz! 产品新闻、软件下载与技术交流